[% # Internet (IP) protocols. See /etc/protocols %] [% SET ip_protocols = [ { name => 'ip', id => 0, desc => 'internet protocol, pseudo protocol number' }, { name => 'icmp', id => 1, desc => 'internet control message protocol' }, { name => 'igmp', id => 2, desc => 'Internet Group Management' }, { name => 'ggp', id => 3, desc => 'gateway-gateway protocol' }, { name => 'ipencap', id => 4, desc => 'IP encapsulated in IP (officially "IP")' }, { name => 'st', id => 5, desc => 'ST datagram mode' }, { name => 'tcp', id => 6, desc => 'transmission control protocol' }, { name => 'egp', id => 8, desc => 'exterior gateway protocol' }, { name => 'igp', id => 9, desc => 'any private interior gateway (Cisco)' }, { name => 'pup', id => 12, desc => 'PARC universal packet protocol' }, { name => 'udp', id => 17, desc => 'user datagram protocol' }, { name => 'hmp', id => 20, desc => 'host monitoring protocol' }, { name => 'xns-idp', id => 22, desc => 'Xerox NS IDP' }, { name => 'rdp', id => 27, desc => '"reliable datagram" protocol' }, { name => 'iso-tp4', id => 29, desc => 'ISO Transport Protocol class 4 [RFC905]' }, { name => 'xtp', id => 36, desc => 'Xpress Transfer Protocol' }, { name => 'ddp', id => 37, desc => 'Datagram Delivery Protocol' }, { name => 'idpr-cmtp', id => 38, desc => 'IDPR Control Message Transport' }, { name => 'ipv6', id => 41, desc => 'Internet Protocol, version 6' }, { name => 'ipv6-route', id => 43, desc => 'Routing Header for IPv6' }, { name => 'ipv6-frag', id => 44, desc => 'Fragment Header for IPv6' }, { name => 'idrp', id => 45, desc => 'Inter-Domain Routing Protocol' }, { name => 'rsvp', id => 46, desc => 'Reservation Protocol' }, { name => 'gre', id => 47, desc => 'General Routing Encapsulation' }, { name => 'esp', id => 50, desc => 'Encap Security Payload [RFC2046]' }, { name => 'ah', id => 51, desc => 'Authentication Header [RFC2402]' }, { name => 'skip', id => 57, desc => 'SKIP' }, { name => 'ipv6-icmp', id => 58, desc => 'ICMP for IPv6' }, { name => 'ipv6-nonxt', id => 59, desc => 'No Next Header for IPv6' }, { name => 'ipv6-opts', id => 60, desc => 'Destination Options for IPv6' }, { name => 'rspf', id => 73, desc => 'Radio Shortest Path First (officially CPHB)' }, { name => 'vmtp', id => 81, desc => 'Versatile Message Transport' }, { name => 'eigrp', id => 88, desc => 'Enhanced Interior Routing Protocol (Cisco)' }, { name => 'ospf', id => 89, desc => 'Open Shortest Path First IGP' }, { name => 'ax.25', id => 93, desc => 'AX.25 frames' }, { name => 'ipip', id => 94, desc => 'IP-within-IP Encapsulation Protocol' }, { name => 'etherip', id => 97, desc => 'Ethernet-within-IP Encapsulation [RFC3378]' }, { name => 'encap', id => 98, desc => 'Yet Another IP encapsulation [RFC1241]' }, { name => 'pim', id => 103, desc => 'Protocol Independent Multicast' }, { name => 'ipcomp', id => 108, desc => 'IP Payload Compression Protocol' }, { name => 'vrrp', id => 112, desc => 'Virtual Router Redundancy Protocol' }, { name => 'l2tp', id => 115, desc => 'Layer Two Tunneling Protocol [RFC2661]' }, { name => 'isis', id => 124, desc => 'IS-IS over IPv4' }, { name => 'sctp', id => 132, desc => 'Stream Control Transmission Protocol' }, { name => 'fc', id => 133, desc => 'Fibre Channel' }, ] %] [% FOREACH proto = ip_protocols %] [% SET ip_protocols_hash.${proto.id} = proto %] [% END %]