Platon Technologies
not logged in Login Registration
EnglishSlovak
open source software development celebrating 10 years of open source development! Wednesday, May 25, 2022
About Us
Magazine
Open Source
CVS
Services
Index  »  Projects  »  phpMyEdit  »  Bug list  »  Bug #25

Viewing Bug Advanced Details Jump to Bugnotes ] Bug History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000025 core / general major always 2003-02-12 23:36 2006-01-23 01:46
 
Reporter anonymous View Status public  
Assigned To nepto
Priority normal Resolution fixed Platform IIS
Status closed Duplicate ID OS windows 2000 server
Projection none Version php4.
ETA none Product Version 0.6.1
  Product Build all
  Votes 1
 
Summary tons of errors when display_errors set to ON
Description Everytime I turn on display_errors in php this script spits out hundreds of errors of the type:

Notice: Undefined index: filters in c:\inetpub\wwwroot\testing\phpMyEdit-5.2\phpMyEdit.class.php on line 2869

Notice: Undefined index: triggers in c:\inetpub\wwwroot\testing\phpMyEdit-5.2\phpMyEdit.class.php on line 2870

Notice: Undefined index: logtable in c:\inetpub\wwwroot\testing\phpMyEdit-5.2\phpMyEdit.class.php on line 2871

Notice: Undefined index: page_name in c:\inetpub\wwwroot\testing\phpMyEdit-5.2\phpMyEdit.class.php on line 2873

Notice: Undefined index: cgi in c:\inetpub\wwwroot\testing\phpMyEdit-5.2\phpMyEdit.class.php on line 2911

Notice: Undefined index: cgi in c:\inetpub\wwwroot\testing\phpMyEdit-5.2\phpMyEdit.class.php on line 2912

Notice: Undefined index: sfn in c:\inetpub\wwwroot\testing\phpMyEdit-5.2\phpMyEdit.class.php on line 1259

Notice: Undefined index: operation in c:\inetpub\wwwroot\testing\phpMyEdit-5.2\phpMyEdit.class.php on line 1259

Notice: Undefined index: operation in c:\inetpub\wwwroot\testing\phpMyEdit-5.2\phpMyEdit.class.php on line 1263
Steps To Reproduce edit the php.ini to set display_errors = On and then the errors display on any table page produced by the phpmyeditsetup
Additional Information / Solution
Attached Files notices.diff (10,064 bytes) 2004-04-17 12:21
error_report.diff (714 bytes) 2004-04-17 12:21

Bug Notes
nepto
2003-02-16 02:13

Well, this is confirmed. These are notices. If we wanted to have them all fixed, code will be probably huge, what may result into more longer parsing time. However, I will see if it is possible to eliminate such notices, or it is very difficult goal.
 
nepto
2003-04-08 19:51

Some error_reporting() calls were added into phpMyEdit for preventing before notices reporting. Can you confirm, that these warnings do not occur anymore?
 
anonymous
2003-07-13 18:01

Same problem here!!
 
nepto
2003-07-14 01:34

Yeah, this note really helps me! :-/

Could you at least tell me what version you are using? Did error_reporting() call in core class solve this problem?
 
hbernard
2004-04-17 12:22

(I went on this when looking on #227)

this bug can be closed in two ways

1. Have a real deactivation of E_NOTICE

current PME tried to deactivate E_NOTICE, but wasn't successful.

Surprisingly, when prefixed by @, function error_reporting doesn't seem to do anything but retrieving current level.

Uploaded error_report.diff patch fixes this.

2. Fix all occurences of E_NOTICE
As you said in a note above, this is lot of work.

However, I made a ten minutes patch which is a start of such clean up. It fixes immediate notices when using basic options.
(uploaded notices.diff)
I don't think this will make PME much slower.

So, nepto, which way do you prefer ?

1. => apply patch error_report.diff, resolve this bug. PME won't care anymore about E_NOTICE
2. => apply patch notices.diff, tell PME to output E_NOTICES, keep this bug open some time to see what was missed in this patch.

because #227 is about E_Warning, it has to be handled specifically.

I got no opinions on this. Both solutions are OK for me. I'm only sure we can fix it quickly, depending on the way you want.
 
nepto
2004-04-17 13:20

I think we can simply go with [1].

It is really strange, that @ before error_reporting() makes this function do nothing...
 
nepto
2004-04-17 13:35

Simplier version commited into CVS.

Please reopen this bug-report when needed.
 

Copyright © 2002-2006 Platon Group
Site powered by Metafox CMS
Go to Top · Feedback form · Application form
Report bug on PLATON.SK website · Terms of use · Privacy policy